Bei einer Neuinstallation oder einem Update von Exchange 2013 kommt es manchmal vor, dass Autodiscover nicht mehr richtig funktioniert. Oft sind die web.config oder andere beteiligte Dateien unabsichtlich verändert worden. Ein Neuerstellen über das Exchange Admin Center führt oft nicht zum gewünschten Ergebnis, da hier nicht alle Dateien neu erstellt werden. Im Folgenden zeige ich kurz das Vorgehen über die Exchange Management Shell.

Das Autodiscover Virtual Directory

Um herauszufinden, welche Virtual Directories Autodiscover auf den verschiedenen Servern hat, verwenden wir den Befehl Get-AutodiscoverVirtualDirectory

get

In unserem Fall gibt es auf den zwei beteiligten CAS-Servern jeweils ein entsprechendes Virtual Directory.

Remove

Um auf jeden Server das Autodiscover Virtual Directory zu entfernen verwenden wir den Befehl Remove-AutodiscoverVirtualDirectory -Identiy SERVER\DIRECTORY

remove

SERVER entspricht hierbei dem Namen des jeweiligen CAS-Servers, DIRECTORY dem vollständigen Namen, den wir zuvor über Get-AutodiscoverVirtualDirectory erfahren haben. Sollten Leerzeichen in einem der 2 Namen vorkommen, muss man das Ganze in Anführungszeichen setzen.

Neuerstellung

Um das Virtual Directory nun vollständig neu zu erzeugen, verwenden wir den Befehl New-AutodiscoverVirtualDirectory -Server SERVER.

new

Hier muss man natürlich SERVER durch den entsprechenden Servernamen des CAS-Servers ersetzen.

Mit diesen Befehlen haben wir nun das komplette Autodiscover-Verzeichnis inklusive web.config neu erstellt. Man darf nun natürlich nicht vergessen eventuell vorher angepasste Berechtigungen oder Umleitungen erneut zu setzen.